/ vuex

Fix Vuex in Internet Explorer

Vuex requires Promises which is not supported in Internet Explorer 11 and earlier versions.

In the console you will find something like:

SCRIPT5022: [vuex] vuex requires a Promise polyfill in this browser.
client-bundle.js (19,1698)

The fix is simple:

Install the es6-promise package

npm install --save es6-promise

And then import the polyfill in your entry point (i.e. src/main.js)

import 'es6-promise/auto'